T500 e Windows 7

Ieri il mio socio mi ha chiamato perchè il suo portatile Lenovo T500 (qualche mese di vita) con Vista qualche minuto dopo il boot si bloccava con un BSOD. Fatta una breve diagnosi telefonica abbiamo deciso di vederci in ufficio (anche se siamo in ferie). In pochi minuti di tentativi mai visti così tanti BSOD (se devo dire la verità che una cosa del genere non ci è mai capitata). Probabilmente un qualche aggiornamento/installazione (Microsoft? Lenovo?) ha caricato un driver non corretto. Dato che il PC bootato in modalità safe funzionava, dato che si doveva passare a 7, verificato che il VHD prodotto dal backup di Vista in qualche modo si riusciva a montare e a sfogliare, abbiamo deciso per una nuova installazione di Windows 7, riservandoci di investigare più a fondo solo in caso si fosse ripresentato il problema .

Il T500 in questione è una macchina più che decente con un processore Intel doppio core a 64 bit, 4GB di RAM, un disco SATA, lettore di impronte digitali, masterizzatore DVD, WiFi, Bluetooth, lettore di schede SD, doppia scheda video Intel/ATI, uscita HDMI e un display da 15” 1/4 con un risoluzione di 1600qualcosa x 1045circa.

Al boot Windows 7 (a 64 bit) ha riconosciuto praticamente quasi tutto. E interessante notare che però ha fatto un po’ di confusione con le schede video. In pratica era convinto di avere due schede con un display ma non aveva ben capito che stava usando la scheda Intel sul video interno che sembrava agganciato alla ATI. Per farla breve il sistema funzionva ma lo schermo era nero. Fatto il logon alla cieca, il video si è illuminato come se fosse un video aggiuntivo. Ho quindi usato la sequenza Win-P per visualizzare correttamente il desktop (probabilmente se si agganciava un video esterno non c’erano problemi). Il fatto è che questo PC ha una gestione anche troppo sofisticata del video: ad esempio, in caso di alimentazione a batteria, utilizza la grafica integrata Intel mentre, in caso di alimentazione da rete, utilizza la scheda ATI. E questo succede solamente dopo che si sono caricati gli appositi tool Lenovo. Alla fine per evitare problemi e visto che i tool in questione erano beta, ho preferito disabilitare a livello di BIOS la scheda Intel e lasciare solo la ATI (il che, per inciso, libera un bel po’ di memoria RAM centrale e permette di usare una grafica più performante).

Una cosa interessante è che il display, probabilmente vista la grande densità, è stato settato automaticamente a 120 DPI anzichè ai canonici 96.

Windows 7 ha anche riconosciuto ed installato il lettore di impronte digitali (finalmente gestito dal sistema operativo).

La rete è andata immediatamente. E, una volta agganciata la macchina al dominio Windows, anche l’ingresso in rete WiFi (tramite il nostro access point autentificato via Radius/NAP sfruttando i certificati digitali).

Alla fine mancava un driver di sistema ma il sito della Lenovo ci ha fornito una versione beta che pare funzionare benissimo.

Abbiamo anche installato Virtual PC RC ma questo purtroppo non supporta guest a 64 bit. La cosa non ci è piaciuta e allora abbiamo deciso di testare VirtualBox. VirtualBox ha due vantaggi: supporta i file VHD e supporta guest a 64 bit (su host a 64 bit ovviamente).

Al momento sembra funzionare tutto egregiamente. E Windows 7 su questo T500 è una bellezza.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: